Jump to content
TCSCOUT

Jazz Dv-150/dxg-567/dxg-125 Wiring Using The Bf Control Board

Recommended Posts

Updated..............

 

I tested it it for 5 days with no failures...I was able to put it out in the field Sunday Oct 16...I will not get to see video until the last weekend in Oct when I go out for the special youth hunt.

 

Hopefully I will be able to get some video to post.

 

Steve

Share this post


Link to post
Share on other sites
 
 
I have built 3 now using post #22 and they work great.

 

Thanks for the update, you probably don't need a drawing to do one anymore :) .

Share this post


Link to post
Share on other sites
 

I have done 6 builds with it and works great. I am using a 12v SLA battery to power array, Kit98, and exchanger with 6.8ohm inline resistor. Works like a charm!!!

Share this post


Link to post
Share on other sites
 
I have done 6 builds with it and works great. I am using a 12v SLA battery to power array, Kit98, and exchanger with 6.8ohm inline resistor. Works like a charm!!!

 

Thanks, I appreciate you guys (Firemanjim, predator bass and usmcatfish) helping out with this. Glad they are all working.

Share this post


Link to post
Share on other sites
 

It is not in TCSCOUT's diagram so do not add it. I am referring to the jumper from the camera common port on the bf board to the negative battery input for board power on the bf board like we do on the 567's. I screwed up and just "assumed" the jumper needed to be there for the 125 as well as the 567. I WAS WRONG!!! Chris (212) was on the phone all afternoon one day figuring that one out. Between Chris and Ron (Egbertdavis) they helped me trouble shoot the first one. Thanks Guys!!!

Share this post


Link to post
Share on other sites
 
It is not in TCSCOUT's diagram so do not add it. I am referring to the jumper from the camera common port on the bf board to the negative battery input for board power on the bf board like we do on the 567's. I screwed up and just "assumed" the jumper needed to be there for the 125 as well as the 567. I WAS WRONG!!! Chris (212) was on the phone all afternoon one day figuring that one out. Between Chris and Ron (Egbertdavis) they helped me trouble shoot the first one. Thanks Guys!!!

Thanks Jim! Just getting ready to wire up my 125's. Saved me a headache I am sure.

 

Thanks TCSCOUT for all the optional wiring diagrams.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×