Jump to content
BowmanPa

Need Help With A P52

Recommended Posts

 

Wow you guys give up to easy. At this point you can not hurt it so go at it. Observe and look for something out of the ordinary. You said it was dropped. Look at that area. Did you reseat the ribbons. I may have a lens assembly.

Share this post


Link to post
Share on other sites
 
 
The P52's that will not power up are cheap on ebay most of the time.

 

 

I bought a couble P52 and P32 off of Ebay saying they would not power up or len shutter will not close but i have been able to get them to work. This one has me scratching my head.

Share this post


Link to post
Share on other sites
 
Wow you guys give up to easy. At this point you can not hurt it so go at it. Observe and look for something out of the ordinary. You said it was dropped. Look at that area. Did you reseat the ribbons. I may have a lens assembly.

 

 

I took it apart and did not see anything out of place and reseated all the ribbons too.

Share this post


Link to post
Share on other sites
 
I might have one I will look when I get home.

 

 

Thanks walleyjoe and Buckshot for looking to see if you have a len assembly.

 

Another Michiganer wallyjoe. I lived there till I was 13 then moved to PA.

Share this post


Link to post
Share on other sites
 

not sure on the p52 exactly but open it up and remove the back of the ccd like you are doing an ir conversion, had a p41 that was giving me issues and opening it up and closing it up did the trick, can't hurt to try. Also don't tighten the ccd screws up too much when you put it back together. check and make sure all the ribbons are in tight too, if someone removed the ribbon without opening the latch it might not have good enough pressure to seat the ribbon well, I have added a small piece of scotch tape to the back of the ribbon after it was inserted to give a little more umph to the latch.

Share this post


Link to post
Share on other sites
 
not sure on the p52 exactly but open it up and remove the back of the ccd like you are doing an ir conversion, had a p41 that was giving me issues and opening it up and closing it up did the trick, can't hurt to try. Also don't tighten the ccd screws up too much when you put it back together. check and make sure all the ribbons are in tight too, if someone removed the ribbon without opening the latch it might not have good enough pressure to seat the ribbon well, I have added a small piece of scotch tape to the back of the ribbon after it was inserted to give a little more umph to the latch.

 

 

I took the whole camera apart this evening and all the ribbons got reseated and I did take the CCD screws out and even took the lens assembly off the board and everything connected to it except the lens assembly it's self and the veiw finder. Cleaned everything and put everything back together and still get the error. I guess I'll just use it as a parts camera because I have other cameras that I can be working on. Thanks everyone for your help.

Share this post


Link to post
Share on other sites
 

I have tried taking apart the lens assemblies on these as well to find the problem with no luck. I have had 4 or 5 of them at one time with this issue that if I didn't change out the lens assembly got parted out.

Ben

Share this post


Link to post
Share on other sites
 
 

I took apart the zoom part of the lense assembly once and soon realized that even if I did get it fixed I would never be able to get it put back together.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×