Jump to content
Sign in to follow this  
Archery Hunter 24

Dead Slavemaster

Recommended Posts

I had a remote slave flash in which the slavemaster quit. I was wondering if anyone had one they haven't used laying around that they would like to part with?

Share this post


Link to post
Share on other sites
 

Are you sure it quit if the CDS gets wet that will cause a issue most times its something else than the slavemaster

Share this post


Link to post
Share on other sites
 

I just dealt with a issue like this. I thought it was the Slavemaster. Ended up being the flash capacitor on the Viv 2800. What is it doing?? Maybe we can help you diagnose the problem. 9 Times out of 10 it will be something other than the Slavemaster from my experience.

Share this post


Link to post
Share on other sites
 

Most likely isn't the Slavemaster, they are very reliable boards. Check all of the wires to make sure one hasn't broken at it's solder connection. I have had that happen a couple of times.

Share this post


Link to post
Share on other sites
 
I just dealt with a issue like this. I thought it was the Slavemaster. Ended up being the flash capacitor on the Viv 2800. What is it doing?? Maybe we can help you diagnose the problem. 9 Times out of 10 it will be something other than the Slavemaster from my experience.

 

The board won't turn on. The green light is not lighting up when I turn the switch on, and I can't hear anything charging or turning on.

Share this post


Link to post
Share on other sites
 

It may be fixable, you can send it to me if you want me to try for you.

Share this post


Link to post
Share on other sites
 
It may be fixable, you can send it to me if you want me to try for you.

 

Thanks 212... If I can't find a solution, I will be sending it out to you.

 

 

Share this post


Link to post
Share on other sites
 

Green light not turning on!!! check the voltage to the board before anything else is done, Could be something as simple as bad battery holders or a broken wire/ bad solder coonection from holders to the board, You did check the Batteries for a full charge correct?

Share this post


Link to post
Share on other sites
 
Green light not turning on!!! check the voltage to the board before anything else is done, Could be something as simple as bad battery holders or a broken wire/ bad solder coonection from holders to the board, You did check the Batteries for a full charge correct?

 

Yes the batteries are brand new, and the leads are soldered properly onto the board's + & - contacts.

Oh and Happy Birthday!

Edited by Archery Hunter 24

Share this post


Link to post
Share on other sites
 
Sign in to follow this  

×