Jump to content
Sign in to follow this  
9toes

P41 Want Power Up

Recommended Posts

Guys it has been a while since i built a cam or worked on one, so help me out. I built this cam for a friend several years ago, it has a BG1 control board. The camera quit powering up, i removed the hack and now the green light will light up and go back off without powering on. Any help would be great.

Share this post


Link to post
Share on other sites
 

Batteries. Batteries. Batteries!!! Take some tweezers and lift up battery contacts down inside cam too. My bet is the BATTERIES!

Share this post


Link to post
Share on other sites
 

DaXX you where right, i put a couple of duracell out of one of my cams and bingo powered up thanks a lot.

Share this post


Link to post
Share on other sites
 

Allways the easy things

Share this post


Link to post
Share on other sites
 

Hey Bruce-Glad you got that thing working again so easily. I'm looking forward to modern gun to try out the new stand. Didn't know you were an old cam hacker!

 

Randall

Share this post


Link to post
Share on other sites
 
Hey Bruce-Glad you got that thing working again so easily. I'm looking forward to modern gun to try out the new stand. Didn't know you were an old cam hacker!

 

Randall

yea, Randall i started a long time ago. Quit and started building deer stands. Hope you kill a good one, send me a picture if you do. ritterb@sbcglobal.net

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×