Jump to content
Firemanjim

Question On Picaxe Output?

Recommended Posts

The chip I am using is a Picaxe 20M2. My question is when a pin goes HIGH in Output will it put out enough voltage to open the mosfet on a sister board or do I need a amp??? Also when the pis is just sitting there does it need to be tied to a ground with a 10k???

Share this post


Link to post
Share on other sites
 
 

You shouldn't need the 10K resistors with that chip. It should operate a Sister Board fine unless you are powering the chip with lower voltage than what we normally use? Some of the new chips will run on lower voltages but then the output will be lower too. If you are using around 4.5 volts, give or take a volt it should be OK.

Share this post


Link to post
Share on other sites
 

Jim, with the 14m2 chips I that I use for the fasthack add on board I put a 1k between the chip pin and the opto to avoid spikes and false triggers, this was Gary's suggestion. I use the 1k for between both the chip and the opto and ground and opto. You shouldn't need to tie the unused pins to ground, that chip should have pullups that you can use for the unused pins. The sister boards already have a resistor on them so they may not be needed at all, I'm not sure if the resistors on the sister board are inline with the ground connection though.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×