Jump to content
Sign in to follow this  
bayouhunter

W290 Blue Screen

Recommended Posts

I have a W 290 that I kept as my hunting pack cam. took end of season photos with it and worked perfectly. Problem is, I forgot it there and the battery went dead. it stayed that way till last week. when I put a charged battery in it will power up make a musical sound, but then the screen is just a light blue and nothing else. I know normally when the battery goes dead or is left out for a long time this happens, and you have to put the date in, then the rest of the functions come on, but I cant see it to get that far? is there a fix for the LCD, or is it toast? Thanks for any help, Tim

Share this post


Link to post
Share on other sites
 

Tim, There are a couple of things you can try. When the camera powers up in the clock set screen, press the down arrow three times, and then press the control button once. This bypasses the clock set screen and the lens will extend. If the lens extends, press the shutter button to see if the camera takes a picture. If the camera takes a picture, then all you need to do is clean and re-insert the LCD cable. Also, if you have the cable where you can connect the camera to your TV, the camera will tell you what's going on.

Bob

Edited by dgrad

Share this post


Link to post
Share on other sites
 
 

Well it is the LCD that went out. I finally found my camera cables and hooked it up to the TV. Everything works now and it takes pics. Just cant see anything on the screen. Will still work for a build. Thanks for the help Bob

Share this post


Link to post
Share on other sites
 

Tim, You can still use the camera without the LCD for a trail camera. Seven years back I posted tips on using the W230 with no LCD. You can find that info at Camtrapper under the camera hacks and tutorials section under the topic W220/230. The W290 and the W 230 use the same LCD. I have a spare IF you need it. I suspect all your camera needs is for the LCD cable to be cleaned and re-seated. I don't see how the LCD could have gone bad in a camera that was not being used. If you decided to use the camera with no LCD, you should disconnect the cable because it is the back-light that consumes battery power. I also have a tutorial on the W290 at Camtrapper. I did not like the 290 and I did not use it but for one season. When set for video, the camera does what I call focus hunting. It will go out of focus and re-focus several times on one video clip. The H series cameras have way better video, and the W230 has a better flash and takes better still images. Here is a W230 pic from a few days ago. In my opinion, the W230 is the best of all the W series cameras, and I have used them all. I have built about 50 of these W230's and I am still building them.

Bob

post-5081-1477188899_thumb.jpg

Share this post


Link to post
Share on other sites
 
 

The W230 is slower than the 290, 2.1 seconds.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×