• Announcements
     
     
    • Badgerbuckhunter

      Prayers for a longtime Member   11/05/2017

      The Church mass shooting that happened today, was Peggy Wardens Church. She was one of the people killed today and her grandson was shot in the arm and is in surgery. Lets keep her in our thoughts and prayers. I made a topic in the "Cabin" I will keep everyone updated as I get information.
     
bassadict69

P32 Setup Batteries Dead After About 70 Pics

14 posts in this topic

I have a P32 setup using SS board and 4 AA externals. After as few as 70 pics, the batteries are drained to the point the camera will not stay on. The only thing I knew to do was pull the camera batteries to see if it was getting power from the externals...it is.

 

Now what? Any ideas?

Share this post


Link to post
Share on other sites
 

What type of batteries you using?

Share this post


Link to post
Share on other sites
 
 

You should be using rechargeable batteries inside the camera and alkaline batteries for the externals.

Share this post


Link to post
Share on other sites
 

I will try that, but it does the same thing regardless of whether I use all alkalines or some rechargeable. I will try swapping them and putting it back out!

Share this post


Link to post
Share on other sites
 

p32's don't like alkiline batteries in the camera, use rechargables in camera and alkiline in externals.

Share this post


Link to post
Share on other sites
 
 

I have a similar set up, P32 camera, SS board with externals to the camera.

 

I use rechargeables in the camera, 2 C cell alkalines for externals and I have never seen the the rechargeables drain down. I can leave this set out for months and as long as there is room on the Sony memory card, it will be taking my picture when I get there.

 

The thinking about the externals being alkaline is that 2 alkalines should indicate about 3.0 - 3.2 volts and they should drain first while keeping your camera rechargeable batteries topped off. The rechargeables will be at a lower potential, coming in at about 2.8 V.

Share this post


Link to post
Share on other sites
 

Make sure your rechargeables are still in good condition. How old, what kind, try different ones......

Share this post


Link to post
Share on other sites
 

They are several years old but very seldom used...I will buy some new ones just to be safe!

 

Share this post


Link to post
Share on other sites
 
Make sure your rechargeables are still in good condition. How old, what kind, try different ones......

This is what I was thinking

Share this post


Link to post
Share on other sites
 

I'm never able to get a P32 not in a set up to even turn on with alkalines so agree with the rechargables/lithiums

Share this post


Link to post
Share on other sites
 

If it's not a battery issue. It could be the flash capacitor is shot and needs to be replaced. Turn the flash off and see if that solves the issue. Or the shutter assembly being badly misaligned can drain the batteries in a hurry.

Share this post


Link to post
Share on other sites
 

Bought some new rechargeables and put the cam on my deck to catch us coming in and out of the house. I got about 150 pics, then swapped the card for a larger 2gb card and it is still going strong a day and half later. I plan to pull the card tonight to see how many are on it, recharge the batteries and get it back into the woods!

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now