• Announcements
     
     
    • Badgerbuckhunter

      Prayers for a longtime Member   11/05/2017

      The Church mass shooting that happened today, was Peggy Wardens Church. She was one of the people killed today and her grandson was shot in the arm and is in surgery. Lets keep her in our thoughts and prayers. I made a topic in the "Cabin" I will keep everyone updated as I get information.
     
Jonnie Wilson

S600 Black Screen

10 posts in this topic

I just got an S600 off ebay and when I turn it on the lens extends like normal and all setting icons appear on the screen but other than that the sreen is black, (no error message) If I point it directly at a bright light it doesn't alter still remains black.

 

I fired off a couple of pics and the flash works but review the pics and of course they are black.

 

Opened it up and there is no sign of moisture or and obvious damage to anything.

 

Removed the lens assembly and cleaned the 3 ribbon cables, re seated them..put it back together and still a black screen.

 

Any suggestions or is this another for the parts box?

 

Thanks

Share this post


Link to post
Share on other sites
 

if you got another lens assembly or robe it from another cam looks like a broken ribbon there is 6 fuses but I try lens before I take it apart ben

Share this post


Link to post
Share on other sites
 

Have you popped the memory card in a computer to review the pics? If the pics are good on the pc, you should just be able to swap the lcd and fix the problem.

Share this post


Link to post
Share on other sites
 

If your settings icons are showing but nothing when you are taking a pictures and the photos are black then it's a lens issue of some type. You can try swapping the lens like Ben suggested or while taking pictures tap on the lens and see if it might be something stuck. It never hurts to initialize the camera either, you might just get lucky.

Edited by johnnydeerhunter

Share this post


Link to post
Share on other sites
 
if you got another lens assembly or robe it from another cam looks like a broken ribbon there is 6 fuses but I try lens before I take it apart ben

 

 

Have you popped the memory card in a computer to review the pics? If the pics are good on the pc, you should just be able to swap the lcd and fix the problem.

 

 

If your settings icons are showing but nothing when you are taking a pictures and the photos are black then it's a lens issue of some type. You can try swapping the lens like Ben suggested or while taking pictures tap on the lens and see if it might be something stuck. It never hurts to initialize the camera either, you might just get lucky.

Ben I have tried in the past to swap lens's but always end up with focus issues. I think the lens is somehow matched to a particular camera or is set at the programming stage.

 

I have hooked the camera to the computer and the pics are black there as well... not even a hint of an image.

 

No luck with initializing the settings and even a gentle tap on the lens while taking a picture turns the camera off.

 

I think we all agree it's a lens issue but probably one that's beyond repair?

The camera also has the two battery door locking tabs broken and although I can put up with that I think it's destined for the parts box. Thanks for your suggestions.

 

Share this post


Link to post
Share on other sites
 

yes but it tell you if the lens is the trouble they mighten be extending all the way I take apart and check the gears night be a little dirt easy fix ben

Share this post


Link to post
Share on other sites
 
yes but it tell you if the lens is the trouble they mighten be extending all the way I take apart and check the gears night be a little dirt easy fix ben

OK I'll give it a try next weekend.. nothing to lose. Thanks

 

Share this post


Link to post
Share on other sites
 

It sounds to me this is a parts camera someone put together and sold as a non working camera. Whenever I bid on something non working I always look at the sellers feedback and see what they have bought or sold in the past.

Share this post


Link to post
Share on other sites
 

when you power up the camera give it a wack on your hand as the lens is extending

Share this post


Link to post
Share on other sites
 

I tried the wack on the hand trick at the start and it turns off even with a gentle wack.

Camera was listed as fully functional and in excellent condition, cost $40. Complained that the item was not as described and got a full refund. I got to keep it so it owes me nothing.

Edited by Jonnie Wilson

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now