Sign in to follow this  
Jonnie Wilson

S600 White Screen

5 posts in this topic

I've had a s600 sent to me for possible repair.

The LCD screen is white when the camera is turned on. I took the screen out and swapped it for another but the problem persists. Disconnected all ribbons and cleaned them with alcohol and reseated them but still no good.

Any suggestions? Thanks

 

Share this post


Link to post
Share on other sites
 
On ‎12‎/‎5‎/‎2017 at 4:30 AM, Jonnie Wilson said:

I've had a s600 sent to me for possible repair.

The LCD screen is white when the camera is turned on. I took the screen out and swapped it for another but the problem persists. Disconnected all ribbons and cleaned them with alcohol and reseated them but still no good.

Any suggestions? Thanks

 

I have this happen and it was the ribbon all the time I don't think a fuse can do it it got be the ribbon even bought camers with that trouble good luck ben

Share this post


Link to post
Share on other sites
 
56 minutes ago, bobopool said:

I have this happen and it was the ribbon all the time I don't think a fuse can do it it got be the ribbon even bought camers with that trouble good luck ben

Thanks Ben,  I'll pull the ribbons out again and give them another clean. 

Is it OK to clean the connector end that the ribbon pushes into with alcohol also? 

Share this post


Link to post
Share on other sites
 
2 hours ago, Jonnie Wilson said:

Thanks Ben,  I'll pull the ribbons out again and give them another clean. 

Is it OK to clean the connector end that the ribbon pushes into with alcohol also? 

If you do be very careful the spring wires that connect with the cable are finer than frog hairs and are easy to bend. I would look at the connector on the board with a magnify glass and make sure they are all intack.

Share this post


Link to post
Share on other sites
 
2 hours ago, Badgerbuckhunter said:

If you do be very careful the spring wires that connect with the cable are finer than frog hairs and are easy to bend. I would look at the connector on the board with a magnify glass and make sure they are all intack.

no I just clean ribbin I use lighter fluid work for me ---ben

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this