Jump to content

Recommended Posts

I have an s600 that won't fire the flash. I checked the flash cap against a good one and it appears to be ok. For some reason the cap isn't charging although the LCD display shows the green indicator to indicate it is charging. After trying to get it to fire buy taking a few pics if i then remove the batteries and try to discharge it with my resistor I don't even get the faintest spark. Even tried touching the terminals with my finger...not even a tingle.

All ribbons seem to be in good condition and I can't see any corrosion anywhere.  Apart from the flash everything else works as it should.

Any suggestions?  Thank you.

Share this post

Link to post
Share on other sites

I think you're right about the main board, I tried initialising the camera but that didn't help.  Another one for the parts box. 

10 hours ago, johnnydeerhunter said:

It could be the main board, you can try initializing the camera and see if that helps.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now